Deploy error Skype for Business Cloud Connector – CredSSP

Last week i ran in to some errors while re-deploying a Cloud Connector, Changed some settings in the INI and while starting the redeploy gave me the following error:

Preparation phase started...
The configuration file for Cms server setup is generated in C:\Users\Administrator\CloudConnector\ApplianceRoot\Instances\2.1.0\ExportedConfig\ServerConfig-Cms.ini.
Preparation phase finished.
Deployment phase started...
Enabling credential delegation for NTLM on host machine.


#text : false
#text : true
#text : true
#text : false
#text : true
#text : Relaxed

Hidester LeaderBoard GIF Banner

[192.168.214.3] Connecting to remote server 192.168.214.3 failed with the following error message : The request is not supported. For more information, see the about_Remote_Troubleshooting Help topic.
+ CategoryInfo          : OpenError: (192.168.214.3:String) [], PSRemotingTransportException
+ FullyQualifiedErrorId : 50,PSSessionStateBroken
[192.168.214.3] Connecting to remote server 192.168.214.3 failed with the following error message : The request is not supported. For more information, see the about_Remote_Troubleshooting Help topic.
At C:\Program Files\WindowsPowerShell\Modules\CloudConnector\Internal\MtSetup.ps1:294 char:13
+             Invoke-Command -ComputerName $machineIP -Credential $doma ...
+            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : OpenError: (192.168.214.3:String) [], PSRemotingTransportException
+ FullyQualifiedErrorId : 50,PSSessionStateBroken
Trying to exit current manual maintenance mode.
Successfully exit manual maintenance mode.
[192.168.214.3] Connecting to remote server 192.168.214.3 failed with the following error message : The request is not supported. For more information, see the about_Remote_Troubleshooting Help topic.
At C:\Program Files\WindowsPowerShell\Modules\CloudConnector\Internal\MtSetup.ps1:294 char:13
+             Invoke-Command -ComputerName $machineIP -Credential $doma ...
+            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : OpenError: (192.168.214.3:String) [], PSRemotingTransportException
+ FullyQualifiedErrorId : 50,PSSessionStateBroken

After some diging in to this problem i found some people having same issues with other Microsoft products. Last March Microsoft released the CredSSP update and this prevented connecting to vulnerable systems using older authentication methods.

If the HYPER-V Host is patched with the latest updates and your VMs are not up to date with the latest bits and OS updates you will run in to this problem.

Solution:

Launch the CMD prompt as Administrator and paste belows code, reboot the server and start the installation again:

REG ADD HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters /v AllowEncryptionOracle /t REG_DWORD /d 2

This isue also occurs to the Audiocodes Appliance when you want to do a re-deploy.

You may also like..

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.